Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 18, 2026 - 10:30 UTC
Scheduled
We are deploying a targeted enhancement to increase our APK upload capacity, so teams working with larger builds can upload and execute tests with a higher size restriction.
This deployment will occur with no downtime or service disruption. Our team will closely monitor the system post-deployment to ensure stability and optimal performance.
Posted May 18, 2026 - 09:25 UTC
This scheduled maintenance affected: Automation Executor and Automation Recorder.