Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 16, 2025 - 11:00 UTC
Scheduled
We’re excited to announce a new set of enhancements aimed at improving visual debugging, test reliability, and workflow flexibility in QApilot. This update will be deployed with zero downtime or service disruption.
What’s New
- Freeze Frame in Execution Reports: QApilot can now analyse execution videos to automatically detect frame freezes, highlight them on the report timeline, and provide direct playback for faster issue identification.
- Apply Healed XPaths from Reports: When auto-healing resolves a test step, you can now apply the updated XPath directly from the report for future executions.
- Deep Link Recording: Record and reuse deep links during test creation to streamline navigation flows and reduce repetitive steps across Android and iOS.
- Tap by Coordinate (Configurable): Choose whether QApilot verifies via element image or taps directly on the recorded coordinate for finer control and flexibility.
Our team will be monitoring this rollout closely to ensure a stable experience. If you encounter anything unexpected, please reach out to our support team.
Thanks!
Posted Oct 15, 2025 - 12:01 UTC
This scheduled maintenance affected: Automation Executor, Automation Recorder, and QApilot Platform.