Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 12:30 UTC
Scheduled
We’re rolling out a new set of enhancements focused on improving visual validation, cross-platform stability, and overall testing accuracy. This update will be deployed with zero downtime or service disruption.
What’s New
-Toast Message Validation You can now validate toast messages directly during execution, enabling more reliable checks on transient UI notifications.
-Project Settings UI Enhancements Project Settings has been refreshed for better usability, clarity, and easier access to key configuration options.
-Element Image Comparison for Visual Validation Added support for comparing element images during execution, allowing fine-grained visual checks for UI accuracy and regressions.
-Clear Text Support for Non-Textbox Elements QApilot now supports clearing text via keyboard input even on non-textbox elements, improving coverage for unconventional input fields.
-iOS XPath Generation Improvements XPath generation for iOS elements has been enhanced for better consistency, reducing flakiness and improving element stability across app versions.
-Crawler Improvements & Fixes General improvements to crawler stability, flow coverage, and handling of complex navigation patterns.
Our team will monitor the rollout closely to ensure a smooth experience. If you encounter anything unexpected, please contact our support team. .
Posted Nov 25, 2025 - 07:03 UTC
This scheduled maintenance affected: Automation Executor, Automation Recorder, and QApilot Platform.