Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 05, 2026 - 12:30 UTC
Scheduled
We're rolling out enhancements focused on recorder capabilities, test case management and crawler intelligence. This update will be deployed with no downtime or service disruption.
What's New - 1. Biometric Authentication Support - Fingerprint authentication is now handled automatically during recording and execution, for tests running on LambdaTest. 2. Import Steps and Functional Blocks - Users can now bring in existing test steps from any module and test case, or import functional blocks directly into an active recording session without leaving the Recorder. 3. Create Functional Blocks During Recording - Steps recorded in an active session can be grouped into a new functional block on the fly, or inserted into an existing one, using a simple toggle within the Recorder. 4. Clone Test Steps - Each step in the test case steps listing now has a Clone option. The cloned step inherits all configurations from the source and is inserted immediately after it, with subsequent steps re-indexed automatically. 5. Reset App Keyword - New keyword is now available: Reset App clears the app cache and relaunches a fresh instance on Android 6. Find Mappings for Functional Blocks - A new option surfaces all test cases where a given functional block is in use, enabling impact assessment before modifying shared components.
Additional improvements include expanded crawler intelligence - featuring recursive exploration of leaf nodes and new BDD step generation capabilities at a test case level, along with other enhancements.
Our team will monitor the rollout closely to ensure a smooth experience. If you encounter any issues, please reach out to our support team.
Posted May 04, 2026 - 18:12 UTC
This scheduled maintenance affected: Automation Executor, Automation Recorder, and QApilot Platform.